The forums were recently upgraded, and this may alter behavior or break things. If you notice problems, check and report them in this thread

240 Modified 240: loss of power below 2500rpm at high load

jamesincJames (@jamesinc) Oz Volvo Ice Fortress
Since sorting the Brapwagon out, I've found it has a flat spot if say you're in third gear, revs around 2000rpm, if you go WOT (or close to it, inb4 someone says WOT map) you get very flat power, sometimes even a bit of a waver in power delivery. If I roll off the throttle and bring manifold vac up a bit, it goes away. I can also et around it by shifting late and keeping revs up high.

This is probably related to the cam and head mods, which give this engine a 280 degree duration, circa 11:1 static CR, and 112 degree LSA. There's also a phenolic spacer between the head and manifold, and the exhaust valves are 38mm, intake 46mm.

The only theory I've heard about it is that there is a harmonic developing in the inlet that is stalling airflow past the intake valves. I wonder if reducing exhaust back-pressure might help this, or if I will have to remap the ignition curves to get around it.

Current EMS is chipped LH-2.4 and chipped 116 EZK

Comments

  • Does it idle ok?

    I tried running a KG8 cam on LH2.2 (like an idiot) and it idled like a rotary which sounded epic but it was not ideal for actually driving the car. MAF was hating the pulses of air until the revs got way up and you side stepped the clutch. Fun, but not socially acceptable for daily driving unfortunately.
    nugget_940
  • jamesincJames (@jamesinc) Oz Volvo Ice Fortress
    It has a lumpy idle but otherwise idles fine. Interesting you say it might be the AMM getting confused
  • Or just the reality of running a big cam?
  • JakeNZJakeNZ (@JakeNZ) South Auckland, NZ
    I think I have a factory K Cam in my B23E... you only feel power at around 3k, but, It seems to get down on power when its dirty...

    Try giving the car a wash and you might find it again.
  • Yeah it's down on torque with a K, but there is no 'flat spot'
  • Did you port right out to the gasket on the exhaust and has it just developed or has it been evident since the rebuild? What exhaust setup do you have?
  • Easy/old school way to check if its related to cam/head mods is to put a vacuum guage on the intake and see what it pulls at idle and if its steady or jumps around.
    egads
  • jamesincJames (@jamesinc) Oz Volvo Ice Fortress
    Or just the reality of running a big cam?
    Yeah I mean that's my first
    Easy/old school way to check if its related to cam/head mods is to put a vacuum guage on the intake and see what it pulls at idle and if its steady or jumps around.
    Yeah was hoping to have done this already but can't find my good vac gauge. I got an ebay special on the way
Sign In or Register to comment.