C30 C30 last rights?

howdy. if any of you remember my obscene contactless buy of the 2010 / 2.4i/40000km C30, that arrived undetailed and unserviced and a smokers car. I have spent the past weeks cleaning it amd catching up on overdue servicing. During this time some start up condensation/ white smoke of note. Motor serviced flushed,conditioned,filters cjanged same as brake pads/rotors. The has run really smoothly before and after service...... til now.

i put it in for a coolant flush and it came back f@@#$d. on pickup it blew clouds of white smoke, then motor started rocking a little and rough, white changed to blue smoke quickly. pressure testing okayed coolant and oil pressure was, ,"not bad" but local garage diagnosed valve stem seal leaks. Local volvo mech advised very expensive and not recommended rel to value of car. wreckers have motors but agreed to costly to rotate engines. ahhhhh 12grand in a few weeks.

but why did it suddenly fail on coolant change? why is engine rocking (a little)? Could it be PCV,piston rings, or any chance less serious?

the body is pretty good but not worthy of several grand to fix ) i dont have it. i am trying to arrange a proper diagnosis by a mobile volvo mech. Any thoughts before I resign to wrecking it?

cheers

undertaker the

Comments

  • Has it overheated?

  • SpacSpac @Spac Canberra-ish.

    Valve stem seals won’t go from fine to f$&ked quickly, and definitely not to the point of making it run badly.

    Your description says that it is NOT the valve stem seals.

    Pulling the spark plugs will give you a hint - one plug that is particularly dirty/oily or conspicuously clean is a hint to the actual problem.

    Do you trust the workshop that did the coolant flush?

    Something related to overheating does seem like the most likely cause here: either accidentally running the car without coolant or mixing incompatible coolants and having them turn to jelly (and then not circulate around the motor).

  • White smoke could be as simple as the brake master cylinder leaking fluid into the vacuum booster, which then gets sucked into the inlet manifold and burned. Could also be a clogged PCV - they're common failures.

    However it would be inconceivable (to me at least) that the valve stem seals are failing - I replaced the engine in our S40 T5 due to massive and prolonged overheating (original complaint was that the heater stopped working 2 weeks before - that would be the lack of water then...). Block was warped so it was cheaper to throw in another engine. I pulled the old motor apart for curiosity - at 150,000km there was no noticeable wear on anything - ring gaps were perfect, bearings all looked new, no lip on bores etc. I couldn't believe how little evidence of wear there was. (I've grown up with Holdens and Leyland products - wear is a way of life.)

    There has to be something simple going on. I really can't imagine that apart from overheating there could be anything terminal going on.

    Spac
  • SpacSpac @Spac Canberra-ish.

    I don’t know about this era of Whiteblock, but it is reasonably common for an early one to collapse the piston rings when overheated.

  • Yes I said APART FROM OVERHEATING. I've already replaced one engine due to overheating (no, it wasn't me...)

    The piston rings just lose tension. Of course it is possible that whomever did the flush caused an overheating event due to incorrect bleeding, but you would think that this would be a one-off boil which isn't usually catastrophic. I haven't found that the P1 models are particularly difficult to bleed, so I'm still struggling to see how permanent damage could be done by flushing coolant.

  • 40,000 km in ten years -- could lack of regular use be the contributing factor? Could it have been sitting unused for some time and might it come good with some regular and maybe hard use?

    When does it smoke? All the time or just at start up or after idling for a while, or after accelerating at the bottom of a hill?

    There are common problems with the PCV. Does anything change if you pull the dipstick while it's running? There is also a test you can do with a rubber glove that might be worth trying.

    Engine mounts don't last long on these, which might explain the rocking.

    Are you losing coolant? Coolant leaks and overheating is common due to leaking overflow tanks or radiator hoses, and the gauge doesn't respond quickly.

Sign In or Register to comment.