S90 2010 XC60 Transmission Issue

Hi All,

Got a problem at the moment with transmission on 2010 XC60. The car jerks when shifting into drive and it's really hard especially after long drive, however the drive itself seems OK. The mechanic that looked at it, says that valve body needs replacing and because oil is very dark recommends recondition as well.
The quote for valve body replacement is $3800 and replacement and recondition is $6500.
So, just wanted to ask if that's reasonable or not?
If not, can you recommend someone else in Melbourne south east area.

Thanks
«1

Comments

  • Which engine and which trans?
    T5 with powershit or something else?
  • It's a D5, not sure about transmission
  • Aw 6 speed, generally highly reliable

    Had the engine mounts ever been swapped?
    How many km on the car? Trans ever been serviced?

    Talked to berry auto yet?
  • Ex850RSnoopy @Ex850R Somewhere Over the Rainbow. Melbourne.
    That's Berry Motor Group or Voldat or Masons Prestige.
  • It's done around 110k.
    No repairs has been done at all and trans hasn't been serviced (unless it was part of scheduled service, but don't think so)
    Didn't talk to any of these guys. Took it to BBEAuto in Elsternwick because they are on the way to work and i wanted someone to look at it straight away.
  • +1 for checking the top torque mount and front hydraulic engine mount. They take lots of abuse on the diesels and would cause clunking into drive.
  • Hmmmm, if mounts are the issue wouldn't it be jerking all the time?
    So far it's doing it only after about 30 min driving.
  • Hmmmm, if mounts are the issue wouldn't it be jerking all the time?
    So far it's doing it only after about 30 min driving.

    transmissions (even brand new ones) do jerk when shifting gears... the engine mounts isolate this from the car... the jerk changes depending on how warm stuff is just like everything else...
    So answer is yes you might only notice when warm...
  • I see, sounds like second opinion is needed.
    Still curious if price quoted is OK?
  • Ex850RSnoopy @Ex850R Somewhere Over the Rainbow. Melbourne.
    Go to the places recommended above.
    Quality, service and good people at each place.
    You won't be ripped off.
  • Our local dealer referred a customer with a t6 xc60 to the gearbox specialist for a rebuild and the only issue was the torque mount!!! Luckily they brought it to me for a second opinion
    egads
  • Thanks guys. Taking it to Masons Prestige tomorrow. Will let you know what they say.
  • Thanks guys. Taking it to Masons Prestige tomorrow. Will let you know what they say.

    Let us know what they say
  • Ex850RSnoopy @Ex850R Somewhere Over the Rainbow. Melbourne.
    Tell em the ozvolvo blokes say hello.
  • VolvoDegerDeger @VolvoDeger Melbourne
    edited January 2018
    you caught me on my day back Alex,,,,,so no codes logged at all and oil was very black,109,000 klm I suggest we do a oil flush and reset counters. Also noted engine oil leak at front of engine and rear wheel bearing noise, so I told alex lets give it a few days to flush through the system as to me it felt like a sticking valve
    Also got another xc60 the same and this auto bangs into gear with 162,000 klms but car not here for this issue ..............cheers steve
    Ex850R
  • I have an MY11 XC60 D5 and it does this too, basically once the car is warmed up and you stop and then when you go to put it back into drive after being in park it will engage a little harsh. It is not like this at all when cold or has cooled down a bit and it does not do it all the time.
    I get it most when dropping the kids off at daycare which is a 10 minute stop after a 20 minute drive, it clunks back into drive almost every time when I jump back in the car to continue on to work.

    A little bit of searching on some of the international volvo forums tells me this is actually a pretty common problem with this transmission.
  • VolvoDegerDeger @VolvoDeger Melbourne
    edited February 2018
    how many klms and have you done a oil flush first, is it auto or mounts?,,,also what area are you in.
  • 157k kms and no I have not flushed the transmission yet. I'm in Sydney.

    I don't see how an intermittent harsh engagement of drive from park/neutral could be mounts?
Sign In or Register to comment.