My second Volvo C70

edited October 2016 in Modern
I'd like to introduce everyone to Sonja, my Saffron Pearl 1998 Volvo C70.

She has 212000kms on the clock and is in reasonable condition for her age. Gave her a wash this morning before taking the pictures. There's still work to do such as getting a bit of rust cut out from above the windscreen and fixing the dent in the front left panel as well as some minor scuffs and dings. Other items on the list are fixing the ABS module (probably bad solder joints), getting the AC working (compressor not engaging) and tracing the source of an occasional misfire. Longer term there's replacing the suspension all round and then focusing on the engine upgrades.

In the meantime I'll simply enjoy driving her about.

w1HJeX3h.jpg
fGqRpkTh.jpg
9qazuy0h.jpg
0yODS3Ch.jpg
fO0s7euh.jpg
wo6tp4Rh.jpg
I0J6R31h.jpg
OldnDecrepit
Current: 1990 Gold Volvo 740GLE "Inga"; 1996 Gold Volvo 960 "Sofia"; 1998 Saffron Pearl Volvo C70 "Sonja"; 1974 Wattle Yellow Volvo 164 "Viktoria"
Previous: 1996 960 "Olga"; 1999 C70T5 "Britt".
«1

Comments

  • Nice got to love a saffy in the sunshine
  • Ex850RSnoopy (@Ex850R) Somewhere Over the Rainbow. Melbourne.
    Those USA front indicators?
    cancer sucks
  • edited September 2016
    Yes apparently. I've got wipers to put on too.
  • Ex850RSnoopy (@Ex850R) Somewhere Over the Rainbow. Melbourne.
    Headlight wipers?
  • Sorry yes headlight wipers.
  • Ex850RSnoopy (@Ex850R) Somewhere Over the Rainbow. Melbourne.
    Did you get new motors etc? I need one motor and to sort out all the hoses for my R project. I forget how they ran now of course!
    New arms and blades too.....
    Maybe eBay.
  • Not new. Previous owner took them off. Don't even know if they work.
  • Ex850RSnoopy (@Ex850R) Somewhere Over the Rainbow. Melbourne.
    Put power on them first to check....
  • Good idea.
  • Vee_QueVee_Que (@Vee_Que) South Eastern suburbs Melbourne.
    I like the interior. Not seen it before but looks good!
  • It is a bit strange. Joe replaced the dash top with the darker one as he didn't like the light (cream?) one that was on it. The wood features have been replaced but that was how it was originally.

    Lots of work to be done on Sonja yet. ABS/TRACS lights are on and the AC doesn't work (compressor doesn't engage). Suspension could do with some work too.
  • I love it with the dark top

    Ive got most everythibg you could want parts wise in stock new in box so give me a ring one day cause i would like to clear it out
    (Project car canceled)
    I think you need to add i was in an s80 with three wheels getting pulled backwards and was told to "hold on shit is about to get real".
  • I love it with the dark top

    Ive got most everythibg you could want parts wise in stock new in box so give me a ring one day cause i would like to clear it out
    (Project car canceled)

    Tell me more as I need a few things.
  • Had a 98 v70t5 with dead aircon pump
    Bought lots of bits and then pulled it apart
    Found oil filled metal shavings through the entire system which just killed any possability of salvaging it
    Cause of this and a spare car have a complete set of known good or new ac bits

    Also have both 98 and 99 doner cars with good working abs bits
  • I need an ABS/TRACS module.
    Might need a AC compressor but I need to find out why mine doesn't engage at all.
  • I need an ABS/TRACS module.
    Might need a AC compressor but I need to find out why mine doesn't engage at all.

    no gas would be my #1 guess
  • So do you have a working ABS unit and for how much?
  • Well I've got my repaired ABS unit in the car and the lights are off and the TRACS seems to be switching on and off using the dash switch.

    AC still needs repair and there's an intermittent miss when driving. I replaced the Crank Angle sensor (twice) as that was supposed to be triggering the CEL to no avail. I then replaced the wiring from the loom to the sensor connector and the problem is better but still there. Next thing to do is replace the ignition leads and coil (ordered from FCP Euro).

    I'm beginning to suspect something to do with the throttle plate as the miss seems to be when there are slight changes to the throttle. If you plant your foot the car simply accelerates normally (with the big turbo boot in the backside of course).
  • Replaced the ignition leads and coils and did some test driving. I'm no longer getting the CEL about the crank angle sensor but there is still an intermittent miss. It's not regular and so far I can't narrow it down to any particular driving mode. Sometimes it's on acceleration, sometimes just driving along the freeway or locally with no throttle change.

    Next on the list for replacement is the electric cooling fan, coolant bottle, cap and two hoses. Might have to get the sensor too.
  • Ex850RSnoopy (@Ex850R) Somewhere Over the Rainbow. Melbourne.
    I get that miss too. I have a solenoid in the auto to replace which allegedly causes this issue as well?
    I think all other bits are replaced as what you have done.
Sign In or Register to comment.