Reminder: videos and articles you find on the web all belong in the off-topic section, even if they are about Volvos.

240 B230F not running, turns over but won't start

gavinhGav @gavinh Parmelia, Perth

so I have this problem, the car, 91 240 b230F.

it turns over, has spark, and plugs are always wet when I remove them, occasionally it will fire but not run, done a compression test, cylinder 1 is around 150psi, 2, 3 & 4 are around 175 psi, but that shouldnt stop it from running.

reset the timing belt as it was 2 teeth off on the dizzy pully.

checked the engine temp sensor that's reading 2, 2,354 kOhms on both cricurts,

all the injectors are firing.


What am I missing?


cheers

Gav

«1

Comments

  • carnut222Greg S @carnut222 Daylesford VIC

    Did you check the ECU coolant temp resistance on the pin(s) at the ECU? I had a prob where I had a bad connection at the ECU coolant temp connector (which was new), so it was randomly giving very high resistance readings back at the ECU, which led to the engine flooding. Sounds very similar to your symptoms. So if it's like mine it could be corrosion or bad connector at the temp sender. I was able to temporarily (semi-permanently LOL) fix it by using a zip tie to put pressure on the temp sender connector wire (pulled it up tight towards the inlet manifold)...I guess that improved the connection and seems to have resolved the issue until I can investigate further.

  • carnut222Greg S @carnut222 Daylesford VIC

    The other thing to investigate is fuel pressure and to check that the fuel pressure regulator diaphragm hasn't perished...remove the vacuum reference hose from the fuel pressure regulator and make sure fuel isn't dumping out through the regulator into the inlet manifold.

  • gavinhGav @gavinh Parmelia, Perth

    @carnut222 yeah measured at the ECU for the temp sensor, will check the FPR thought

  • I'm interested that you mentioned cam timing. Why is this? Was the cam belt replaced? If not, how did this situation begin? Some more detail would help, how long have you owned the car etc

    bgpzfm142
  • gavinhGav @gavinh Parmelia, Perth

    Ah good question, I just bought the car as a non runner! yeah it's been at a garage before I took it over.

    interesting enough it had a crank position sensor faulf on the wee black box thingy when it last got checked be the garage and hasn't been running since.

    I have always been getting a spark and assumed it was ok, on checking the resistance of the sensor 1-3 I'm getting 0.2 Ohms 1-2 173.4 Ohms and 1-2 180.4 Ohms.

    but when I was about to put the plugs back in I turned it over and I got no spark, just wondering if there might be a link.

  • carnut222Greg S @carnut222 Daylesford VIC

    Has a new crank sensor been installed yet?

  • gavinhGav @gavinh Parmelia, Perth

    nope that's on the list to get, see if Repco stocks them

  • Hey mate ive been reading through your thread and id recommend checking out your Fuel Pump Relay, which is located behind your glove box. It's a little white one, stupid common issue

  • gavinhGav @gavinh Parmelia, Perth

    yeah thanks both pumps are working, and there is good flow and volume from the pipe going to the fuel rail.

  • Try AFI / Cooldrive too.

    I ordered my last one through Autobarn, came from Premier Auto Trade. Was around 50 bucks with a two year warranty

  • Have you checked timing?

  • The crank RPM sensor is Volvo p/n 271949, JFYI. If the hoses to the heater core have burst before, stray coolant reacts with the plastic outer cable sheath going to the sensor and rots it. Sometimes you'll get an intermittent condition where the wires to the sensor occasionally short out when the insulation goes bad, right at the junction point where the wires go into the sensor. The result of this being sometimes you'll see spark, other times not.

    Other things to cross off the list -

    You've checked for other codes on the ECU and EZ-K?

    You've checked the orientation of the distributor to #1 and TDC?

    You've checked the plug leads are in the correct firing order on the dizzy cap? (firing order 1-3-4-2, clockwise rotation)

    reset the timing belt as it was 2 teeth off on the dizzy pully.

    Uh oh. Are all the little dots on the timing belt pulleys lining up correctly?


    Anthony
  • gavinhGav @gavinh Parmelia, Perth

    @bgpzfm142

    Yeah I aligned the timing marks yesterday, so all is good there, firing order is correct too, there are no faults on the LH2.4 or ezk,

    I ordered a new crank sensor this morning, hopefully it's here today!

    The dizzy and rotor, the rotor a little right of the mark on the dizzy when at tdc.

    Cheers

  • gavinhGav @gavinh Parmelia, Perth

    so got back to the car today and replace the crank position sensor and the car is still the same with no change,

    will start again tomorrow when there's is more light

  • You have fuel, fuel injection, spark

    You have checked cam timing, ignition timing (not adjustable but the order of the spark plug leads in relationship to the distributor) and cylinder compression

    Has this engine ever started whilst it's been in your possession?

  • Failed plugs? if the ignition timing is good the cas is operating while the timing light blinks. BPR7ES i think, easy enough to find.

    Have you tried unplugging the injectors and attempt start using aerostart?

  • gavinhGav @gavinh Parmelia, Perth

    @ramrod, no the car has never ran in my possession, but the last owner said he was driving then it lossed power and started to hunt, then never started again.

    going to pick up an intank pump this afternoon, as the last owner replaced the external pump.

    done a compression test afew weeks ago cylinder 1 was around 150 psi the rest were 175 that was dry.

    checked the firing rotation on the leads and checked sparkplugs countless times with firing order

  • gavinhGav @gavinh Parmelia, Perth

    replaced the intank pump, still no start, double checked the wiring to both pumps, it's all good, pulled the injector rail out and turned over the car, all 4 injector are firing, pull all the plugs and they all have spark.

    it's got to be something really simple! everything is there to make it go but it just won't fire up

  • gavinhGav @gavinh Parmelia, Perth

    just to double check. on the distributor #1 is the one closest to #1 cylinder and the firing order is 1342

Sign In or Register to comment.