S/V40 S40 T4 MAF problem... Apparently...

Alright, so this has been causing me problems for a while now!

So I have a 2000 S40 T4. It is coming up with an engine light and the traction control light as well. The fault code on my cheap OBD2 reader says MAF high input voltage. I have replaced the MAF with no obvious change.

This is where it gets weird. The problems are all over the place, when the light comes on it misfires really badly and had been getting worse. From originally just enough to be noticeable to now where it nearly didn't make it up a slight hill in second gear. Also only did this rarely, now can't drive more than a km or so before it does it, and it feels life it drops 2 cylinders now and wants to stall. Has stalled a few times now at idle sitting at lights as well. Also brings up that it is much worse once the car warms up and seems to be worse on a hot day or in the afternoon when the outside temp is higher.

Next part is the Thermo fans, which runs after the car is turned off, I assume that is when it gets a bit hot. Started it yesterday and ran only for probably 2 minutes and the fam wouldn't turn off, I had to disconnect the battery to stop it. Has plenty of coolant and oil, temp gauge never goes past half way...

Anyone got any clever ideas, I have plenty of spares and a parts car but no idea... Thinking of swapping the ECU out next. After that, replacing the wiring for the MAF or maybe the other way around.

This thing is a stack of fun when it works but it's becoming a problem, I need a car that works more often than it doesn't.

Comments

  • 240240 @240 Canberra

    Might be worth finding someone with VIDA as it's much more comprehensive than a generic code reader.

    The similar problem I had with the white S40 turned out to just be a loose connector on one of the coil packs, which I think is a relatively common problem.

  • 2nd VIDA. Another option is a poor CPS signal.

  • So random updates... So I have tried another MAF and the problem didn't change.

    I tried a few other bits and pieces; checked that it has fuel pressure, I don't have a gauge but definitely has fuel! Changed the dstc module of whatever it's called, changed nothing the T/C light is still on.

    Also changed out the ECU as I have a couple, no change there except Spac was correct the ECU is a pair with the immobilizer, so wouldn't start the car, but the fault code came back straight away and the fans continued to run after the car was turned off (basically cold).

    Changed all the leads and coil packs... again, no change

    Changed the temp sender and thermostat... Turns out the parts car has a different plug on the sender and hasn't solved the problem of the fans, but made it a little better?

    The one thing that has made a difference, I was chasing wiring problems and found which pins on the ECU relate to the MAF, the signal wire (green/orange I think) (pin 15 I think) was almost cut in half. So with a bit of stuffing around I soldered a small piece of wire in there and I think I have fixed that up... Now for the random, the misfire problem seems to have gone away for now, but the ECU now shows MAF low input!?!?!? Now it also idles really low, sometimes stalling and is running very rich (always did a bit).

    I'll update a bit more when I get home, have a photo of the wiring problem...

  • SpacSpac @Spac Canberra-ish.

    The MAF high/low change around could be related to self-learning??

  • @Spac I had thought that.

    I'm going to go back a little and try and use some logical fault finding rather than the hit and hope that I have been doing so far.

    @timbo trying to do this in a logical sequence so if I can't find it, you guys don't have an absolute mess when I bring it in next week. 🙂 Lol, I'm sure your looking forward to that! 😂

Sign In or Register to comment.