Oz Volvo Nationals 8-10 November - register today! ozvolvo.org/nationals

240 Green top injector with resistor pack won't fire

My car: 88 240

Donor car: 88 740 turbo

Today I put my green top injectors, and wired the resistor pack in using the included diagram, and the car wouldn't start.

I put my stock injectors back in, and bridged the wires back together, and it started fine.

I tested the green top injectors by connecting them through the resistor pack to my car battery while squirting carby cleaner through them, and they open and close just fine, so the injectors aren't the issue.

I'll be swapping in the ezk117 and ecu soon, as I'm doing my turbo swap in stages, but does the stock ECU not work with a resistor pack or something?

Comments

  • You dont need a resistor pack for the green tops.

  • The car came with a resistor pack though. Perhaps when I swap to the turbo computers I'll need the resistor pack?

  • Stock 740/940 injectors are low impedence so need resistor pack but greens are high impedence like your stock n/a injectors

    ALVO360
  • *stock 740/940 turbo injectors are low impedence*

    ALVO360
  • My stock injectors are 0-280-150-734, which are listed as high impedance, and the green tops from the turbo are 0-280-150-357, listed as low impedance, according to this list:

    http://users.erols.com/srweiss/tableifc.htm


    All this stuff is new to me, so I'm not sure exactly what I'm talking about, but I'm pretty sure to run the green tops, I should need the resistor pack. I'm wary of trying without the resistor pack as it can damage the ECU I think 😬

  • There may be a bit of confusion between “green tops” and what are the standard 1988 740T injectors. The standard 1988 740T injectors require the resistor pack. I think the term “green tops” refers to some later injectors that didn’t require the resistor pack. I’ll have to go out and have a look at the 88 740T engine I have sitting in the shed - IIRC the injectors may be blue or green, and yes, it has the resistor pack.

  • Maybe double check the polarity? Would they still open if the + and - wires were accidentally swapped on the injectors?

  • Polarity doesnt matter with injectors.


    Yeah if your running stock turbo injectors you need the resistor pack. Calling them green tops made them sound like s60r injectors.

    carnut222
  • What did you wire the 12v+ input up to when you tried it

  • Sorry guys, I called them green tops, because only the top part is green 😂


    My 240's stock wiring is the green/red wire from the ecu (positive) joined to all 4 green wires on each injector, and then the same for the ground side.


    The modified wiring is the green/red wire from the ecu, into the resistor pack, and then each resistor goes each single injector, and the ground remains the same.


    When I tested the injectors, I tested them on my battery running through the resistor pack, and they opened and closed fine.


    So I'm unsure why they won't open when hooked upto the ECU. Does the stock 240 ECU not work with a resistor pack?

    timbo
  • I can't see why the ecu would stop it working. Did you confirm the wire you spliced had 12v with a test light/multimeter?

  • I didn't get as far as to test it with the resistor pack and turbo injectors in place, but I just poked it with my multimeter with the stock injectors in, and giving me voltage.


    I'll install the resistor pack and turbo injectors again tomorrow after work and try with a multimeter.


    I appreciate all your helpao far mate, thanks a lot 😉


  • I'm not sure where I went wrong the first time, but I put it all back together to troubleshoot, and it fired up fine.


    So, problem solved 😂

  • Nothing like solving the problem without finding the solution! ;) Well done!

Sign In or Register to comment.