2019 Nationals in Bathurst are 8-10 November, just over three months away! Make sure to register at ozvolvo.org/nationals!

780 96 turbo cranks and no start

so went to take the wagon out today and the Red Baron presented with the engine turns over and no start.

Earlier in the week she showed signs something was going wrong when it failed to start 1st go (as she does always) , then started 2nd go but felt a little rough then all settled down to normal running and thought nothing of it.

I had a quick look - but it's dark now, but the fuel relay clicks when key is in,.... there appears to be no fuel at the rail. Other than checking the fuse is there anything else that would stop the fuel pump from running?
At the moment not checked for spark but looks to be a fuel issue.

Comments

  • No fuel at the rail would tend to suggest fuel pump failure. There is an old trick that you bang the bottom of the tank with a lump of wood whilst turning the engine over and it will often cause the pump to kick in. Saw it done by an NRMA guy once and tried it myself a couple of times.
    jamesincRolvo
  • jamesincJames (@jamesinc) Oz Volvo Ice Fortress
    ^ I've used that trick before, on multiple cars, works a treat
    Rolvo
  • Or take the cover off the top and tap that also works
    Rolvo
  • ICEDVOVOBOXY (@ICEDVOVO) Dural NSW
    edited April 19
    I assume you've checked the fuse box for the fuel pump circuit?
    I had that happen to me once on my brand new excavator after only a year.
    Can you believe they combined the fuel pump circuit with the horn circuit!!!
    The horn trigger wire intermittently chafed on a lever in the joystick and was blowing the fuse.
    Wasted a day to figure that out after first replacing the perfectly ok fuel pump.
    Bobcats now made in mexico so what do you expect, but engineered in US so cant really blame the mexicans
    ALVO360Rolvo
  • Ex850RSnoopy (@Ex850R) Somewhere Over the Rainbow. Melbourne.
    ^damn!
  • Have you actually confirmed if you're getting fuel to the rail? Id be checking for spark too, to narrow down whether it is fuel related. Could well be a Crank Position Sensor issue. I had the exact symptoms you mentioned when I had my CPS fail (admittedly on a Saab 9-5).
  • Ex850RSnoopy (@Ex850R) Somewhere Over the Rainbow. Melbourne.
    Maybe cam position sensor? Lhs rear cam.
    ALVO360
  • But there is no fuel at rail.
    Needs to solve that first
    Rolvo
  • RolvoBruce (@Rolvo) Sydney, NSW
    thanks guys. I ended up pulling out the fuel pump - bench tested it with 12v - got it to work intermittently which was still no good.
    I assume even though the pump is a sealed unit it still has carbon brushes? or wear parts? After 20 yrs I guess it had run out of go beanz.
    Put in a loan pump from a 94 t5 and got it going for last long weekend getaway.
    New pump will go in shortly.
    ALVO360ICEDVOVO
Sign In or Register to comment.